Can anyone help?

I’m relatively new to Prism. I have a TI Super RoboDome. I’m able to run my shutter, camera, and virtually everything with Prism. However, other than the shutter I’m unable to control the dome in any other manner. The included screenshot shows where I’m having trouble. In the screenshot, I’m unable to execute any of the possibilities shown in the shot other than to be able to open and close the shutter. Dome won’t rotate at all. My settings are an LX200 and Compliant Telescope Mount, Dome/shelter handled by ASCOM, Dome type Digital DomeWorks on COM6. Any suggestions as to what I’m doing wrong would be greatly appreciated.

Screenshot (7)|690x288

As far as i can see / know, i don’t see the problem. The Dome Control window looks fine.
I think you mean, you don’t see direction arrows to move your dome " manually"? There aren’t.

The dome can follow your telescope position if you check box: Activate auto track. Witch you have.
Every minute the software will see what the azimuth shift is with your telescope. If it is larger then a preset value, the dome will rotate a bit.

Can you work with your mount? Does it slew to all objects correctly from prism? Yes?
Then have a look at you dome dimensions, do you have entered the right settings inside: Dome Geometric. These fields need to be filled in correctly. (yes, mine also needs to be filled in… )

Can you give us a screenshot of you ascom dome property window?

Thank you

Thanks for trying to help! The Dome Control window is fine, but my dome won’t respond to anything in it other than to open/close. I’m not trying to manually rotate the dome, but want it to respond to the features in the Dome Control window. Open/Close is all I’m able to do. Activate auto track does not work. Reset Az, Synchronize, and everything else do not work. The mount is polar aligned and works ok. But I don’t have any Dome Control other than Open/Close. The Dome Geometry was not entered, so I tried some close guesstimations and still got nothing. I’m not using the TI DDW program, but I wonder if the Dome Geometry needs to be inserted in it. Anymore suggestions will be greatly appreciated!

Screenshot (8)|690x288, 100%

it seems to me that the dome part is a graphical problem we can take a look at on our end. So basically one piece of software needs to do the math the geometry piece. It can create a conflit if a couple are doing it at the same time.
So it is entirely your choice to perform the geometry with the driver or PRISM.

Out of curiosity, can you enable the log in prism as you operate the roof to see what instructions make it onto it?

Thanks for the reply Hamza. If anyone can help, I’m sure it’ll be you. Remember, I’m relatively new at this, so it’s probably my lack of knowledge. I have managed to put the dome together and get everything to work except for the dome rotation/slaving. I would like to be able to control everything from Prism. I deleted the Technical Innovations program totally that runs the Digital Domeworks. However the shutter motor and dome rotation motors do still run through the Digital Domeworks hardware. Prism is able to open and close the shutter, but not the dome rotation. I suspect you’re right about a problem with the dome geometry. The screenshot shows the settings I have based on the dome dimensions (6’ diameter, 54" high, 12" south offset for the pier). They may not be entirely correct, but I figured they are close enough to at least get some movement. I can always tweak everything later. The Ascome dome driver I’m using is from Technical Innovations. I also see Prism is showing an Ascom Digital DomeWorks and Digital Domeworks 2018 choice. So I’m not sure what that’s about. I did get my dome in 2018. The log is showing the opening and closing of the shutter, and my attempt at dome rotation may be listed as well. Sorry this is so long.

Hamza I was unable to get the Log file sent to this location, so I sent it to Contact Us at Hyperion Astronomy. Let me know if you don’t get it and will try to figure out another way.

Thanks I did receive it. For reference, it is great to have Dropbox, upload any file to the Dropbox folder on your computer, and share the link here.

As for the dome…Mmmmm it is rather strange that one motor can be operated but not the other.

I will help you solve this, just need to know how. Let’s get the basics out of the way:

  1. Can you operate the rotation our of the DDW software successfully?
  2. Any connection problems?
  3. any inhibits in place?

Let’s figure this out. Also, I will be able to log in with you through TeamViewer and troubleshoot this together.

  1. I can rotate the dome ok with the hand controller, but not with Prism or any other software (Meade for example). As far as one motor working with Prism and not the other, I too am confused. I will check Dropbox out, thanks.
  2. No
  3. Not sure what you’re asking, but probably no.

So basically it is a driver problem, or an electronics interface problem.
In a nutshell, we need the dome’s control box to have an interface to the computer for software like PRISM can rotate it.

I was wondering if it might be the driver. Ascom only offers the one from TI. Do you have any ideas on what sort of interface might solve this? I’ve added a couple of pics of the outside setup.

So first things first:

We need to make shore that the dome can rotate with the DDW software itself. Without other software.
if this does not work, then you are maybe interested to renew the automation with other drivers like: Lesvedome.net http://www.dppobservatory.net/DomeAutomation/DomeDriver.php
As this was original designed for a HomeDome…

OK. I’ve just reinstalled the DDW software, but will have to train the dome when the weather is better to test it. Stay tuned!

I have a homedome 6. I never tried running it without dome geometry. My recommendation is to do it. Did you successfully run it with DDW?

Jim

I’m sorry I see you tried that. What’s your current status. Did you fix it?

Jim

I’m currently using the following beta version from Tigra - astronomy. They wrote the original version of the DDW for TI. It’s been working for me. Your mileage may vary. Here is the link https://bitbucket.org/tigra-astronomy/ta.digitaldomeworks/downloads/

1 Like

Thanks for sharing Jim, I know they write good drivers.

Thanks for the info Jim. I had seen that site before but hadn’t tried the driver figuring the TI version would be sufficient. I will give the Tigra driver a shot now.